• <Intel.com에 대한 자세한 내용
Masthead Light

Intelligent Platform Management Interface

Software Tools

IPMI, V2.0, Conformance Test Suite (ICTS) Prototype, V6.02

Published July 26, 2005
The IPMI, V2.0, Conformance Test Suite (ICTS) is designed to verify IPMI, V2.0, conformance. ICTS, V6.02, provides support for the IPM, V2.0, conformance testing as well support for previous IPMI versions (IPMI, V1.5, and IPMI, V1.0). It also includes bug fixes found in ICTS, V6.01. Please refer to the release notes and updated user guides for details and list of all the new changes. This software is provided to IPMI adopters only for their internal evaluation.

Note: This tool is a prototype version and is provided "as-is" with no support.

IPMI, V2.0, V1.5, and V1.0, Reference Drivers 
Published January 13, 2005
Intel is offering several IPMI, V2.0, V1.5, and V1.0, drivers reference implementation. The IPMI, V2.0, reference driver supports IA-64 and IA-32 under Windows* NT, Windows* 2000, and Windows* 2003. In addition to the KCS and SMIC interfaces, the IPMI, V2.0, reference driver supports SSIF interface as well. The IPMI, V1.5, reference driver supports both IA-64 and IA-32 under Windows* .NET/2000. The IPMI, V1.0, is available for the Windows* NT/2000, NetWare*, and Linux* OS's. All drivers support the KCS and SMIC interfaces. You must be an IPMI Adopter to use this software. It is provided "as is" with no support.

IPMI, V2.0, Command Test Tool 
Published January 13, 2005, this file contains: a readme file, a binary file, and source code for the utility.
The IPMI command test tool is a low-level MS-DOS* command line tool that allows hex-formatted IPMI commands to be sent to an IPMI baseboard management controller (BMC) that implements the KCS or/and SSIF interfaces. This can be used as an aid in developing and testing IPMI enabled systems. The tool can also send commands to satellite management controllers located on the primary IPMB behind the BMC. This version has been designed to work with IPMI, V2.0; IPMI, V1.5; and IPMI, V1.0, systems. An option for use with IPMI, V0.9, systems is also provided.